PHP: Hypertext Preprocessor, popularly referred to as PHP, is a famous web programming language, which is used to set up dynamic websites with interactive features like discussion boards, online teaching sites or social networking websites. In comparison with static HTML-based websites, a PHP website can serve unique content to each user under the exact same URL. Due to the fact that PHP-based web apps can be managed via one Control Panel tool, which you can log in to using any browser, you will not need to possess any web design know-how or previous experience whatsoever in order to administer a PHP-powered website. The fact that 100s of millions of websites worldwide are built on PHP is indicative of the popularity and the ease of use of the language. You only have to check if the server on which your site is hosted supports the same exact PHP version as the one that you used whilst developing the site.
PHP 4 and PHP 5 Support in Shared Hosting
Our shared hosting servers support different PHP versions, which means that your sites will run without any problems no matter if your PHP scripts are outdated. We know that an old site does not necessarily imply a vulnerable one as you may have performed a lot of mods to its source code. That’s why we support PHP 4, 5.2, 5.3, 5.4 and 5.5 and you can select which one will be enabled for your hosting account. The version can be changed with a single click of the mouse within your Hepsia hosting Control Panel and the new settings will take effect immediately. If you wish to run both newer and older scripts, there is even a possibility to use a different version of PHP for each domain name of yours simultaneously.
PHP 4 and PHP 5 Support in Semi-dedicated Hosting
Even if your sites were created with an older version of PHP, you will be able to host them in a semi-dedicated server account from us, as we support multiple versions running at the same time on our semi-dedicated servers and each of them can be activated for your account with just a click from our in-house developed Hepsia hosting Control Panel. Other than the newest PHP 5.4 and PHP 5.5, we also support 5.2, 5.3 and the older PHP 4. The latter has already been abandoned by the majority of hosting suppliers, but we are convinced that you should not be forced to modify a website that took several years to create, as older script language syntax doesn’t always imply safety loopholes. Quite the opposite, a correctly maintained website using PHP 4 can be more reliable than a negligently maintained one using PHP 5. For your convenience, we’ll also offer you the possibility to choose a different version of PHP for each individual site within your account.